CLI

建VLAN


進入全域模式。
Switch# configure terminal
Switch(config)# vlan vlan_id
Switch(config-vlan)# name vlan-name
Switch(config-vlan)# end

Switch# show vlan [id | name] vlan_name

輸入VLAN ID,進入VLAN配置模式。VLAN ID的範圍為1∼1001。其中,VLAN 1為系統預設VLAN,不能被建立,也不能被刪除。

name vlan-name(可選)為VLAN命名。如果不為VLAN命名,預設在VLAN ID前加0作為VLAN名稱。例如,VLAN0004是VLAN查看並檢驗VLAN配置 show vlan [id | name] vlan_name

 

要將某個port只到某vlan,設定流程如下

1. 模式進到config mode
switch>en
switch>config t

2.假如port 10要加入vlan 2 (可以是GigabitEthernet)
switch #conf t
switch #vlan 2
switch #exit
switch # interface fastEthernet 0/10
switch(config-if) # switchport access vlan 2
switch(config-if) # end

3.觀察vlan設定
switch # show vlan

4.儲存
switch > wr

要將某幾個port只到某vlan,設定流程如下(2960)2013/09/17
1. 模式進到config mode
switch>en
switch>config en

2.假如port 25-36 要加入vlan 25 (可以是GigabitEthernet)
switch #conf t

switch(config)#interface range GigabitEthernet 1/0/25-36
Stack number若無Stack則為1(用sh run可看出來)
switch(config-if) # switchport access vlan 25
switch(config-if) # end

取消某個port 到 vlan X

switch(config-if) # no switchport access vlan X

看目前Trunk之內容
#show interfaces trunk

設Trunk

先指定那個port(也可用上述的 range)如

switch(config)#interface range GigabitEthernet 3/25-36
switch(config-if) #switchport mode trunk
switch(config-if) #switchport trunk allowed vlan all

 

設註解description

先指定那個port(也可用上述的 range)如

switch #conf t

switch(config)#interface GigabitEthernet 1/0/25(要設的port)

switch(config-if) #description "加入文字"

取消註解

先指定那個port(也可用上述的 range)如

switch(config-if) #no description

設定Cisco Switch設備名稱

4503(config)#hostname Switch_name

Show Running-configure 加上參數 | include(或begin...) [關鍵字]
這句話的意思是有眾多顯示畫面的設定檔中找到我們輸入”特定”的關鍵字
sh run | include [關鍵字]

do To run exec commands in config mode

Example:

C4503E_95(config-if)#do show run

show interfaces Interface status and configuration

C4503E_95#show interfaces gigabitEthernet 2/3

Port Channel

http://www.james-tw.com/cisco/etherchannel-config

 

 

Use an FTP Server to Backup and Restore a Configuration

記得ftp server在Lan內,故若備份Wan上的(router)要開firewall的rule,
另外,此法只能使用ftp之根目錄(可以用.20那台)。

In this procedure, an FTP server can be used in place of a TFTP server.

At the Router> prompt, issue the enable command, and provide the required password when prompted.

The prompt changes to Router#, which indicates that the router is now in privileged mode.

Configure the FTP username and password.

CE_2#config terminal
CE_2(config)#ip ftp username cisco
CE_2(config)#ip ftp password cisco123
CE_2(config)#end
CE_2#

Copy the configuration to the FTP server.

CE_2#copy running-config ftp:
Address or name of remote host []? 10.66.64.10
Destination filename [ce_2-confg]? backup_cfg_for_router
Writing backup_cfg_for_router !
1030 bytes copied in 3.341 secs (308 bytes/sec)
CE_2#

Open the configuration file with a text editor. Search for and remove any line that starts with "AAA".

Note: This step is to remove any security commands that can lock you out of the router.

Copy the configuration file from the FTP server to a router in privileged (enable) mode which has a basic configuration.

Router#copy ftp: running-config
Address or name of remote host [10.66.64.10]?
Source filename [backup_cfg_for_router]?
Destination filename [running-config]?
Accessing ftp://10.66.64.10/backup_cfg_for_router...
Loading backup_cfg_for_router !
[OK - 1030/4096 bytes]
1030 bytes copied in 13.213 secs (78 bytes/sec)

Cisco Router 更改telnet(第一層)密碼步驟

1.telnet 至 Cisco Router,輸入 telnet password (enter)

2.輸入 enable,輸入 enable password (enter)

3.Router# configure terminal (enter)
註解 : 進入 configuration mode.

4.Router(config)# line vty 0 4 (enter)
註解 : 進入line mode.

5.Router(config)# password yourpassword (enter)
例如: password abc123
註解 : 設定 password.

6.按 Ctrl + Z (enter)
註解 : 跳出 configuration mode.

8.輸入 write (enter)
註解 : 將設定存檔.

若要使用username + password且要加密:
(config)#service password-encryption


Cisco Router更改enable密碼步驟

1.telnet至Cisco Router,輸入telnet password (enter)

2.輸入enable,輸入enable password (enter)

3.Router# configure terminal (enter)
註解 : 進入configuration mode.

4.Router(config)# enable password yourpassword (enter)
例如: enable password abc123
註解 : 更改enable密碼.
enable secret的層級比enable password高,即若同時設定 enable secret 5678 及 enable password 1234 則enable密碼是5678而非1234
另外enable secret的密碼會加密,在show run時會看不到,而enable password在show run時可以看到,除非有service password-encryption
才能將enable password加密

 

5.按Ctrl + Z (enter)
註解 : 跳出configuration mode.

6.輸入 write (enter)
註解 : 將設定將設定存檔.

Cisco Router 阻擋 telnet(23),www,3128 步驟

目的:限制校外電腦連接校內210.70.129.220這台主機的 23(telnet)、80(www)、3128等Port。
假設:Router接校內網路的Interface是Ethernet0/1。

1.telnet 至 Cisco Router,輸入 telnet password (enter)

2.輸入 enable,輸入 enable password (enter)

3.Router# configure terminal (enter)
註解 : 進入 configuration mode.

4.Router(config)#access-list 101 deny tcp any host 210.70.129.220 eq telnet (enter)
註解 : 設定 access list 來自任何地方到主機 210.70.129.220 屬於 Port 23(telnet) 一律拒絕.

5.Router(config)#access-list 101 deny tcp any host 210.70.129.220 eq www (enter)
註解 : 設定 access list 來自任何地方到主機 210.70.129.220 屬於 Port 80(www) 一律拒絕.

6.Router(config)#access-list 101 deny tcp any host 210.70.129.220 eq 3128 (enter)
註解 : 設定 access list 來自任何地方到主機 210.70.129.220 屬於 Port 3128 一律拒絕.

7.Router(config)#access-list 101 permit ip any any (enter)
註解 : 允許其他 ip 進出.

8.Router(config)#interface e0/1 (enter)
註解 : 進入 interface ethernet 0/1 下.

9.Router(config-if)#ip access-group 101 out (enter)
註解 : 於 interface configuration mode,將 access list 施行於此 interface 上,           任何要離開此Interface的TCP封包,均須經過此access-list規則的檢查,即來自任何地方要到210.70.129.220,port屬於telnet(23),www(80),3128 一律拒絕通過.

12.輸入 write (enter)
註解 : 將設定寫入 startup-config.

 

Cisco Router 阻擋 UDP Port 1434 步驟

1.telnet 至 Cisco Router,輸入 telnet password (enter)

2.輸入 enable,輸入 enable password (enter)

3.Router# configure terminal (enter)
註解 : 進入 configuration mode.

4.Router(config)# access-list 101 deny udp any any eq 1434 (enter)
註解 : 設定 access list 來自任何地方到任何地方屬於Port 1434 一律拒絕.

5.Router(config)# access-list 101 permit ip any any (enter)
註解 : 允許其他 ip 存取.

6.Router(config)# interface e0/1 (enter)
註解 : 進入 interface ethernet 0/1 下.

7.Router(config-if)# ip access-group 101 in (enter)
註解 : 於 interface configuration mode,將 access list 施行於此 interface 上,
            任何要進入此Interface到任何的UDP封包Port屬於1434 一律拒絕進入.

8.Router(config-if)# ip access-group 101 out (enter)
註解 : 於 interface configuration mode,將 access list 施行於此 interface 上.
            任何要離開此Interface到任何的UDP封包Port屬於1434 一律拒絕離開.

9.輸入 Ctrl + Z (enter)
註解 : 跳出 configuration mode.

10.輸入 write (enter)
註解 : 將設定寫入 startup-config.